“… would smell as sweet” wrote Shakespeare. And the program module will work correctly no matter what it is called.
Even so, it is necessary to make the name easier to understand in order to expand it more and more and maintain it for a long time, but it may be necessary to change it as development progresses.
One module in Hept was originally named “Unlock” because it unlocks new stages upon completing a puzzle. After that, the process at the time of puzzle completion was no longer just unlocking, it should be called “Complete”. In addition, when the processing associated with starting and stopping puzzles increased, it became what should be called “PuzzleEvent”. (There is also a plan that can be a separate module for each)
Due to the extension and integration of many modules, including shaders, there are cases where the names are not suitable or are inconsistent with similar modules. At least, there is no choice but to create a list in the document and make it easier to maintain.